Well, as expected, it seems that the board software hasn't adjusted to the time change. So if you want to set the proper time just go into your user control panel and set your time zone to GMT -6 and this should fix things until the next clock change in the spring. Don't forget to turn the daylight savings setting to OFF.